Back to overview
Resolved
Major Updates to our website.
Jun 28, 2026 at 4:32pm UTC
–
Jun 28, 2026 at 6:33pm UTC
Affected services
trucklinemp.com
recruitment.trucklinemp.com
id.trucklinemp.com
Resolved
Jun 28, 2026 at 6:33pm UTC
Maintenance ended
Affected services
Created
Jun 28, 2026 at 4:32pm UTC
We've finished the first part of the maintenance. We are currently getting ready for the partial rollout of the recruitment hub.
Affected services